Announcement

Collapse
No announcement yet.

Blocked myself on my Windows firewall :(

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Blocked myself on my Windows firewall :(

    Hello,

    I was playing arround with some rules in the Firewall and blocked the connection to RDP by mistake
    How can I regain access to my Windows Server?

  • #2
    Hello,

    (We already have a Topic regarding this: https://www.server4you.com/community...ll-in-recovery
    But here I will explain it for you step by step)

    The best way to regain access to the server is over the Recovery Mode, this option you can find in the PowerPanel by going to Hardware -> Recovery:





    On step 4 put in your Email where you want the notification that the recovery mode is active and a temporary password for the recovery season

    "Your password has to consist of 8 characters, contain upper and lower case letters and digits. We recommend to use special characters like ?, !, +, - etc. It's not allowed to use these characters: $, &, <, >, /, \ or %."


    Once the Recovery was started you can connect to the server via VNC (RDP is not enabled in recovery mode).
    In my case I will use tightvnc for the demonstration.

    Open your VNC Client and use the Server IP to connect:



    Then use the Password you selected when you started the recovery:




    You should get a window like this:




    Now go to Start -> Run -> regedit



    Click on "HKEY_LOCAL_MACHINE"



    Go to "File" > "Load Hive"



    Choose your registry -> ?:\Windows\system32\config\SYSTEM
    (In my case its Drive E: look for the one that says Windows)



    Use the Key name "RegTemp" for example



    Your Registry is now reachable under "HKEY_LOCAL_MACHINE\RegTemp"



    Open HKEY_LOCAL_MACHINE\RegTemp\ControlSet001\Services\ SharedAccess\Parameters\FirewallPolicy\ can be also HKEY_LOCAL_MACHINE\RegTemp\ControlSet001\Services\ SharedAccess\Defaults\FirewallPolicy\



    Edit the Value for "PublicProfile" and "StandardProfile" by the point "EnableFirewall" and "DoNotAllowExceptions" to 0.



    Click again on "RegTemp"

    Click on "File" > "Unload Hive"

    Close regedit and stop the recovery mode


    The Server should be now reachable again in Productive mode


    Best Regards,
    Martin

    Comment


    • #3
      https://www.youtube.com/watch?v=BqjAR4f6_fM

      Comment


      • #4
        One computer is assigned a static IP address that falls into the DHCP range IP Address Conflict
        for the local network and the same address is assigned to a computer by the DHCP server

        Comment

        Working...
        X